debian – Synaptic Package Manager:无法应用更改!首先修复破损的包裹.

一直试图以各种方式解决它,但互联网上的所有这些建议对我来说都是无用的.看到一条指令何时帮助其他人,但是没有解决我的问题,这太奇怪了.

当我在Synaptic Package Manager中标记包并按“Apply”时,它说:

Could not apply changes!
Fix broken packages first.

然后我点击Synaptic – >编辑 – >修复破损的包,我得到这个:

An error occurred
The following details are provided:

E: Unable to correct problems, you have held broken packages.
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

有什么方法可以解决这个问题吗?

最佳答案
尝试在Debian上构建Barrier时出现同样的问题…安装libcurl3-nss(单独使用),然后是libcurl4-nss-dev,这给了我一个成功的构建.

(已经安装了libcurl3和libcurl3-gnutls)

转载注明原文:debian – Synaptic Package Manager:无法应用更改!首先修复破损的包裹. - 代码日志