Debian 6升级到Wheezy然后测试发布需要内核升级吗?

Debian 6升级到Wheezy然后测试发布需要内核升级吗?

我正在努力进行喘息的升级.然后我开始测试.每一步升级然后分离升级.我想我可能过度升级了.

无论如何.现在我无法apt-get安装任何东西.

thw@chttl-90092eb8e95ecef8:~/node-v0.10.33-linux-x64$sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 consolekit : Breaks: udev (< 204-1) but 175-7.2 is installed
 libcairo-perl : Depends: perlapi-5.14.2 but it is not installable
 libfont-freetype-perl : Depends: perlapi-5.14.2 but it is not installable
 libglib-perl : Depends: perlapi-5.14.2 but it is not installable
 libgtk2-perl : Depends: perlapi-5.14.2 but it is not installable
 libhtml-parser-perl : Depends: perlapi-5.14.2 but it is not installable
 liblocale-gettext-perl : PreDepends: perlapi-5.14.2 but it is not installable
 libnet-dbus-perl : Depends: perlapi-5.14.2 but it is not installable
 libnet-ssleay-perl : Depends: perlapi-5.14.2 but it is not installable
 libpango-perl : Depends: perlapi-5.14.2 but it is not installable
 libperl5.14 : Depends: perl-base (= 5.14.2-21+deb7u2) but 5.20.1-3 is installed
 libtext-charwidth-perl : Depends: perlapi-5.14.2 but it is not installable
 libtext-iconv-perl : Depends: perlapi-5.14.2 but it is not installable
 libuuid-perl : Depends: perlapi-5.14.2 but it is not installable
 libxml-parser-perl : Depends: perlapi-5.14.2 but it is not installable
 lsof : Depends: libperl4-corelibs-perl but it is not installed or
                 perl (< 5.12.3-7) but 5.20.1-3 is installed
E: Unmet dependencies. Try using -f.

使用apt-get install -f,我得到了

(Reading database ... 154815 files and directories currently installed.)
Preparing to unpack .../archives/udev_215-7_amd64.deb ...
Since release 198, udev requires support for the following features in
the running kernel:

- inotify(2)            (CONFIG_INOTIFY_USER)
- signalfd(2)           (CONFIG_SIGNALFD)
- accept4(2)
- open_by_handle_at(2)  (CONFIG_FHANDLE)
- timerfd_create(2)     (CONFIG_TIMERFD)
- epoll_create(2)       (CONFIG_EPOLL)

Please upgrade your kernel before or while upgrading udev.

AT YOUR OWN RISK, you can force the installation of this version of udev
WHICH DOES NOT WORK WITH YOUR RUNNING KERNEL AND WILL BREAK YOUR SYSTEM
AT THE NEXT REBOOT by creating the /etc/udev/kernel-upgrade file.
There is always a safer way to upgrade, do not try this unless you
understand what you are doing!


dpkg: error processing archive /var/cache/apt/archives/udev_215-7_amd64.deb (--unpack):
 subprocess new pre-installation script returned error exit status 1
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
Errors were encountered while processing:
 /var/cache/apt/archives/udev_215-7_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

我需要为此升级内核吗?我是不是已经这样做了升级和dist-upgrade?
还是我需要重启?

最佳答案
我认为问题是apt-get upgrade或者apt-get dist-upgrade已经更新了内核映像.但是,新内核仅在重新启动时生效. udev包的版本需要新内核.所以它警告我,我的系统当前正在运行的这个旧映像不适用于新的udev并且拒绝安装.

我只是重启系统以使用新内核.然后我运行了apt-get install -f而没遇到进一步的问题.

转载注明原文:Debian 6升级到Wheezy然后测试发布需要内核升级吗? - 代码日志