ruby – 与middleman和Gemfile的依赖关系出错

我对ruby很新,但我想编译一个与中间人完成的项目.

我已经确认使用以下命令安装了所有依赖项:

>> bundle install
Using i18n (0.6.1) 
Using multi_json (1.7.3) 
Using activesupport (3.2.13) 
Using chunky_png (1.2.8) 
Using coffee-script-source (1.3.3) 
Using execjs (1.4.0) 
Using coffee-script (2.2.0) 
Using fssm (0.2.10) 
Using sass (3.2.8) 
Using compass (0.12.2) 
Using ffi (1.8.1) 
Using tilt (1.3.7) 
Using haml (4.0.2) 
Using hike (1.2.2) 
Using rack (1.4.5) 
Using url_mount (0.2.1) 
Using http_router (0.10.2) 
Using json (1.7.7) 
Using listen (0.7.3) 
Using syntax (1.0.0) 
Using maruku (0.6.1) 
Using bundler (1.3.5) 
Using rack-test (0.6.2) 
Using rb-fsevent (0.9.3) 
Using thor (0.15.4) 
Using middleman-core (3.0.13) 
Using rack-protection (1.5.0) 
Using sinatra (1.3.6) 
Using padrino-core (0.10.7) 
Using padrino-helpers (0.10.7) 
Using uglifier (1.2.7) 
Using middleman-more (3.0.13) 
Using sprockets (2.9.3) 
Using sprockets-sass (0.9.1) 
Using middleman-sprockets (3.0.11) 
Using middleman (3.0.13) 
Using rb-inotify (0.9.0) 
Your bundle is complete!
Use `bundle show [gemname]` to see where a bundled gem is installed.

如果我使用Gemfile依赖项进行编译,它会告诉我以下内容:

>> bundle exec middleman build
/var/lib/gems/1.9.1/gems/execjs-1.4.0/lib/execjs/runtimes.rb:51:in `autodetect': Could not find a JavaScript runtime. See https://github.com/sstephenson/execjs for a list of available runtimes. (ExecJS::RuntimeUnavailable)
    from /var/lib/gems/1.9.1/gems/execjs-1.4.0/lib/execjs.rb:5:in `<module:ExecJS>'
    from /var/lib/gems/1.9.1/gems/execjs-1.4.0/lib/execjs.rb:4:in `<top (required)>'
    from /var/lib/gems/1.9.1/gems/coffee-script-2.2.0/lib/coffee_script.rb:1:in `require'
    from /var/lib/gems/1.9.1/gems/coffee-script-2.2.0/lib/coffee_script.rb:1:in `<top (required)>'
    from /var/lib/gems/1.9.1/gems/middleman-core-3.0.13/lib/middleman-core/renderers/coffee_script.rb:2:in `require'
    from /var/lib/gems/1.9.1/gems/middleman-core-3.0.13/lib/middleman-core/renderers/coffee_script.rb:2:in `<top (required)>'
    from /var/lib/gems/1.9.1/gems/middleman-core-3.0.13/lib/middleman-core/core_extensions/rendering.rb:33:in `require'
    from /var/lib/gems/1.9.1/gems/middleman-core-3.0.13/lib/middleman-core/core_extensions/rendering.rb:33:in `registered'
    from /var/lib/gems/1.9.1/gems/middleman-core-3.0.13/lib/middleman-core/core_extensions/extensions.rb:90:in `register'
    from /var/lib/gems/1.9.1/gems/middleman-core-3.0.13/lib/middleman-core/application.rb:160:in `<class:Application>'
    from /var/lib/gems/1.9.1/gems/middleman-core-3.0.13/lib/middleman-core/application.rb:18:in `<module:Middleman>'
    from /var/lib/gems/1.9.1/gems/middleman-core-3.0.13/lib/middleman-core/application.rb:17:in `<top (required)>'
    from /var/lib/gems/1.9.1/gems/middleman-core-3.0.13/lib/middleman-core.rb:16:in `require'
    from /var/lib/gems/1.9.1/gems/middleman-core-3.0.13/lib/middleman-core.rb:16:in `<top (required)>'
    from /var/lib/gems/1.9.1/gems/middleman-3.0.13/lib/middleman.rb:2:in `require'
    from /var/lib/gems/1.9.1/gems/middleman-3.0.13/lib/middleman.rb:2:in `<top (required)>'
    from /var/lib/gems/1.9.1/gems/bundler-1.3.5/lib/bundler/runtime.rb:72:in `require'
    from /var/lib/gems/1.9.1/gems/bundler-1.3.5/lib/bundler/runtime.rb:72:in `block (2 levels) in require'
    from /var/lib/gems/1.9.1/gems/bundler-1.3.5/lib/bundler/runtime.rb:70:in `each'
    from /var/lib/gems/1.9.1/gems/bundler-1.3.5/lib/bundler/runtime.rb:70:in `block in require'
    from /var/lib/gems/1.9.1/gems/bundler-1.3.5/lib/bundler/runtime.rb:59:in `each'
    from /var/lib/gems/1.9.1/gems/bundler-1.3.5/lib/bundler/runtime.rb:59:in `require'
    from /var/lib/gems/1.9.1/gems/bundler-1.3.5/lib/bundler.rb:132:in `require'
    from /var/lib/gems/1.9.1/gems/middleman-core-3.0.13/lib/middleman-core/load_paths.rb:38:in `setup_load_paths'
    from /var/lib/gems/1.9.1/gems/middleman-core-3.0.13/bin/middleman:10:in `<top (required)>'
    from /usr/local/bin/middleman:23:in `load'
    from /usr/local/bin/middleman:23:in `<main>'

我已经安装了一个JavaScript运行时:

>> sudo gem install therubyracer 

如果我尝试编译没有Gemfile,这会给出不同的版本错误:

>> middleman build
    /var/lib/gems/1.9.1/gems/bundler-1.3.5/lib/bundler/runtime.rb:33:in `block in setup': You have already activated listen 1.2.2, but your Gemfile requires listen 0.7.3. Using bundle exec may solve this. (Gem::LoadError)
        from /var/lib/gems/1.9.1/gems/bundler-1.3.5/lib/bundler/runtime.rb:19:in `setup'
        from /var/lib/gems/1.9.1/gems/bundler-1.3.5/lib/bundler.rb:120:in `setup'
        from /var/lib/gems/1.9.1/gems/bundler-1.3.5/lib/bundler/setup.rb:7:in `<top (required)>'
        from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:55:in `require'
        from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:55:in `require'
        from /var/lib/gems/1.9.1/gems/middleman-core-3.1.4/lib/middleman-core/load_paths.rb:30:in `setup_load_paths'
        from /var/lib/gems/1.9.1/gems/middleman-core-3.1.4/bin/middleman:10:in `<top (required)>'
        from /usr/local/bin/middleman:23:in `load'
        from /usr/local/bin/middleman:23:in `<main>'

我不知道我是否会将这个gem添加到Gemfile中,但是必须放入.我不知道我是否误解了ruby或我做错了.如果有人可以指责我的错误,我感激不尽.

谢谢

最佳答案
似乎是一个已知的“问题”,Middleman不能/不会提供这些每个平台的依赖关系,见https://github.com/middleman/middleman/issues/276#issuecomment-4037229.

根据https://stackoverflow.com/a/7860385,您只需将以下内容添加到您的Gemfile:

gem "rb-inotify"
gem "therubyracer"

运行bundle install一次然后捆绑exec middleman build应该可以帮到你.

转载注明原文:ruby – 与middleman和Gemfile的依赖关系出错 - 代码日志