Nginx Passenger Error – libcurl.so.4:找不到版本`CURL_OPENSSL_3′

系统:

> Ubuntu:18.04 LTS
>乘客:5.3.1
> nginx与libnginx-mod-http-passenger

$sudo nginx -t

返回:

PassengerLoggingAgent: /usr/lib/x86_64-linux-gnu/libcurl.so.4: version `CURL_OPENSSL_3' not found (required by PassengerLoggingAgent)
2018/06/04 02:28:40 [alert] 10411#0: Unable to start the Phusion Passenger watchdog because it encountered the following error during startup: Unable to start the Phusion Passenger logging agent: it seems to have crashed during startup for an unknown reason, with exit code 1 (-1: Unknown error)

“`

最佳答案
如果您不依赖于已使用版本4的其他软件,则可以从bionic存储库安装所需的版本3:

sudo apt install libcurl3/bionic

这将要求您删除curl本身,libcurl4和dependend软件.在删除它们之前,请仔细考虑是否需要它们.

您仍然可以通过再次安装libcurl4和删除的软件来回滚.

转载注明原文:Nginx Passenger Error – libcurl.so.4:找不到版本`CURL_OPENSSL_3′ - 代码日志