asp.net-core – Visual Studio 2015中的ASP.NET核心支持?

既然ASP.NET Core随VS 2017一起发布(3月发布),它们将在VS 2015中支持ASP.NET Core多长时间?

我的意思是project.json将不再使用,那么我们是否需要将现有项目移至VS 2017并且不要使用VS 2015来使用ASP.NET Core.

最佳答案
Visual Studio 2015仅支持.NET Core< = 1.1(即project.json).如果您希望使用基于.csproj的.NET Core项目,则需要使用Visual Studio 2017.您可以阅读有关.NET Core Roadmap here的信息.

您可以坚持使用project.json和Visual Studio 2015.但是如果您想迁移到.NET Core 2.0,则需要使用Visual Studio 2017打开您的项目,该项目可以将其迁移到新的.csproj格式.您可以在this blog post中了解迁移过程.

Visual Studio 2017还将为.NET Core 1.0提供稳定的RTM工具(请注意,Visual Studio 2015中的工具仅在预览中).另一个有趣的blog post here讨论了向新项目格式的转变,微软的Joe Morris确认没有计划让VS 2015支持构建/项目系统.

更新

随着Visual Studio 2019的发布,Visual Studio 2015或2017不支持最新的.NET Core SDK.这是compatibility matrix

Compatibility Matrix

转载注明原文:asp.net-core – Visual Studio 2015中的ASP.NET核心支持? - 代码日志