google-app-engine-使用gcloud app deploy部署GAE Flex时出错

突然之间,使用gcloud app deploy部署到GCP时遇到了问题.

创建了一个全新的项目,并尝试从GCP上传示例hello-world应用,但仍然出现以下错误:

错误:(gcloud.app.deploy)错误响应:[3] Docker映像us.gcr.io/gcp-test-8710371/appengine/default.20181106t173450:latest未找到或不是Docker V2格式.请访问https://cloud.google.com/container-registry/docs/ui

app.yaml中:

runtime: nodejs
env: flex

manual_scaling:
  instances: 1
resources:
  cpu: 1
  memory_gb: 0.5
  disk_size_gb: 10

SDK: Google Cloud SDK 224.0.0

我已经检查了容器注册表,并且在那里什么都没有创建.

另外,尝试像此post中那样启用/禁用API,但没有结果.
一个示例Python应用程序可以正常上传,没有问题.

最佳答案
存在影响Flex部署的问题.该问题已在UTC时间07/11大约00:40修复.正如@isharko指出的那样,Flex部署现在应该可以正常工作.

与此相关的还有public issue on GCP’s issue tracker.如果新的相关信息浮出水面,则很可能会在此处发布.

转载注明原文:google-app-engine-使用gcloud app deploy部署GAE Flex时出错 - 代码日志