Laravel 5.8のインストールエラーdatabase.phpの58行目:未定義のクラス定数 ‘MYSQL_ATTR_SSL_CA’

Laravel 5.8をインストールしようとするとエラーが発生します

In database.php line 58:

Undefined class constant ‘MYSQL_ATTR_SSL_CA’

enter image description here

この後、私はサーバー上でアプリケーションを実行しようとしました。それは時々うまくいきます。時にはそれは同じエラーをスローします。 Artisanでもコマンドを実行できませんでした。なぜこれが起こるのか、そしてどうこれを解決するのか?

ベストアンサー
新しいLaravelリリースにはこのエラーがあります。 config / database.phpを見ると、次のようになるでしょう。

    'mysql' => [
        'driver' => 'mysql',
        'host' => env('DB_HOST', '127.0.0.1'),
        'port' => env('DB_PORT', '3306'),
        'database' => env('DB_DATABASE', 'forge'),
        'username' => env('DB_USERNAME', 'forge'),
        'password' => env('DB_PASSWORD', ''),
        'unix_socket' => env('DB_SOCKET', ''),
        'charset' => 'utf8mb4',
        'collation' => 'utf8mb4_unicode_ci',
        'prefix' => '',
        'prefix_indexes' => true,
        'strict' => true,
        'engine' => null,
        'options' => array_filter([
             PDO::MYSQL_ATTR_SSL_CA => env('MYSQL_ATTR_SSL_CA'),
        ]),

セキュリティ保護されたアプリケーションには、データベース名とパスワード、電子メールとパスワード、開発用か本番用かなどの値など、特定のマシンとソフトウェアの設定に関するデータを含む環境ファイルがあります。

Laravelはそれらをグローバル関数env()を通してアクセス可能な定数でロードします。
Laravelには、これらの特別な値を含むファイル.envがあります。それを開き、データベースセクションの一番下に、証明書パスの値を追加します。

DB_CONNECTION=mysql
DB_HOST=127.0.0.1
DB_PORT=3306
DB_DATABASE=blog-db
DB_USERNAME=root
DB_PASSWORD=fakepass
MYSQL_ATTR_SSL_CA=relative/or/absolute/path/to/certificate.extension

あるいは、あなたが私たちのようにMySQL接続にSSL証明書を使うことを計画していないのなら、config / database.phpでそれをコメントしてください:

    'mysql' => [
        'driver' => 'mysql',
        'host' => env('DB_HOST', '127.0.0.1'),
        'port' => env('DB_PORT', '3306'),
        'database' => env('DB_DATABASE', 'forge'),
        'username' => env('DB_USERNAME', 'forge'),
        'password' => env('DB_PASSWORD', ''),
        'unix_socket' => env('DB_SOCKET', ''),
        'charset' => 'utf8mb4',
        'collation' => 'utf8mb4_unicode_ci',
        'prefix' => '',
        'prefix_indexes' => true,
        'strict' => true,
        'engine' => null,
        //'options' => array_filter([
        //     PDO::MYSQL_ATTR_SSL_CA => env('MYSQL_ATTR_SSL_CA'),
        //]),

それは現在Laravel / Laravel masterにあるように:https://github.com/laravel/laravel/blob/master/config/database.php

転載記事の出典を記入してください: Laravel 5.8のインストールエラーdatabase.phpの58行目:未定義のクラス定数 ‘MYSQL_ATTR_SSL_CA’ - コードログ